Sidewinder X-1 SKR 1.4T Marlin (Sensorless Homing/Hemera/ABL) V1.1

  • Corrected M600 definition
  • Reduced Bufsize to 16 from 32 as 16 seems sufficient
  •  Marlin
  • Square Wave Stepping (Beta Feature)
       * Create a 50/50 square wave step pulse optimal for stepper drivers.
  • Tmc2209 Steppers in UART
  • Stepper Current set as follows X: 1000ma, Y: 1200ma, Z: 1000ma, E0: 650ma
  • Sensorless Homing 
    *Bump sensitivity set to 100 for X and Y
    this will need to be configured according to your machine as they all behave differently, these values can be changed on the touch screen and are found under machine settings-parameters, or by the terminal using the M914 command.
    For more information click here
  • Configured for Hemera
  • BLTOUCH with 5 point mesh
  • EEPROM enabled
  • Thermal Runaway for Bed and Hotend Enabled
  • Reversed Extruder Stepper Direction
  • Increased Max Nozzle Temperature
  • Thermistor settings changed for E3D thermistor cartridge
  • E-steps for the Extruder set to 409 per E3d Specifications
  • Classic Jerk
  • Baby Stepping
  • Linear Advance
  • Enabled Quick Home 
     If homing includes X and Y, do a diagonal move initially rather than homing Axis individually 
  • Increased Bufsize
    for printing over serial connections - this will help with printing via USB from the computer or Octoprint. - Tim from TH3D explains why I have made this change.

BTT 3.5 Firmware

  • attached Unified firmware for the BTT 35 v2

14replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • This is so weird.  I've flashed both firmware files and the TFT screen seems to have the icons in the wrong places or something.  They don't line up with the function.

      • Bahij Nemeh
      • CEO
      • Bahij_Nemeh
      • 5 mths ago
      • Reported - view

      Joe Try reflashing, that usually fixes any errors 

      • Joe
      • Joseph_P_Rosiak
      • 5 mths ago
      • Reported - view

      Bahij Nemeh 


      I tried that and numerous different versions of firmware.

      I opened an issue in github on it.


      Everything worked prior to flashing it with this build.  I didn't notice until after I flashed it that the firmware was for E3.26 and I don't have the E model.

      I even tried the version that the touchscreen worked on and it behaves the same way.

      • Joe
      • Joseph_P_Rosiak
      • 5 mths ago
      • 1
      • Reported - view

      Now that was a pain in the butt.  I got it fixed.  So pro tip.  Before you flash firmware to the LCD screen.  Make sure you rotate it to the default orientation.  Otherwise the icons update in the correct order but the button presses are upside down.  I had to calibrate the screen in reverse ignoring where the red dots were actually showing up.

      Like 1
    • Joe it sounds like you have been through the wars, I'm glad you got it fixed :)

  • Is there any chance we could get the firmware but for stock extruder ? If not, could you point to what needs to be changed for this to work with stock extruder + hotend ?

    Thanks in advance

    Like 1
  • Can anyone please help me out. Im new to compiling firmware but I'm not a tech idiot either....far from it......lol....I have a sidewinder x-1 v3 with stock hotend and bed. BLTouch, BTT SKR 1.4 TURBO w/tmc2209 drivers, and BTT TFT35 v3.0...I have tried to meld the settings from a known/working marlin build from Pretend Prusa with the build that is posted here so that my hotend would work properly as well as setting up the new screen....problem is it won't compile. Does anyone have my setup or the marlin build that'll work straight away??? THANK U IN ADVANCE

    Like 1
    • Cameron Miller get in touch with me via facebook and I can try and give you a hand

  • What needs to be done in the firmware to disable sensorless homing?  I’ve commented it out in configurationAdv.h but the end stops all show triggered, so I can’t Home anything. If I place a wrench on the end stop it shows open. 

    • Joe I apologise for the delay in response, I am actually just about to upload another variant that doesn't use sensorless homing or the Hemera, 

  • Hello...I made a few changes to mine, sadly it didn't work. I tried a few different commands and nothing is input to the screen, though when I put M108 it is echoed to the screen. I tried M410 and that did take. I would like to know why M108 isn't working for me

Like2 Follow
  • 2 mths agoLast active
  • 14Replies
  • 2054Views
  • 7 Following